Описание

Описание программы iikoDJ

iikoDJ - это программа для автоматизации эфира радиостанций, клубов, дискотек, казино, магазинов, кинотеатров. Широкие возможности программы позволяют использовать ее везде, где требуется музыкальное оформление. Программа может работать месяцами без вмешательства человека. Встроенный перекодировщик форматов, граббер CD, музыкальная база, генератор плейлистов, расписание, авторегулятор громкости, кроссфейды и множество других функций делают эту программу очень полезным средством для управления вашей музыкальной коллекцией. Простой и удобный интерфейс позволит Вам начать работу сразу же после запуска программы.

iikoDJ состоит из 2-х модулей
Player - это основной модуль. В нем выполняется основная часть работы: запуск и редактирование плейлистов, работа с расписанием, настройка эффектов и многое другое.
Musical Database - сканирует диск на наличие музыкальных файлов, сохраняет список в базу данных. Обеспечивает быстрый поиск по любому полю, массовый редактор тегов, сортировка, статистика, фильтр и т.п.

Системные требования:

Windows 98/ME; XP/2K рекомендуется
DirectX 9
WDM драйвера для звуковой карты
кодек WMA (скачать с сайта www.microsoft.com или отсюда)

Основные возможности:
- поддержка форматов mp3, wma, wav, ogg, CD audio
- плагины для поддержки других форматов файлов (AAC, FLAC, ...)
- индексированная база данных композиций и быстрый поиск по ней
- повышение уровня рекламы и объявлений
- одновременная работа с двумя плейлистами
- использование возможностей многоканальных карт (4.0, 5.1, 7.1 и т.п.)
- поддержка ретрансляции
- возможность создания интернет-радио
- встроенные эффекты: echo, reverb, flanger, tempo, pitch
- 12ти полосный эквалайзер
- поддержка режима плавных переходов (кроссфейдов) между треками
- поддержка плагинов WinAMP и DirectX (через AdaptX)
- автоматический контроль громкости - все файлы играют на одной громкости
- обрезание тишины в начале и конце файла
- 2 независимых выхода: стерео сплит; разделение по каналам на многоканальных картах; использование двух звуковых карт
- расписание (планировщик)
- цветовая индикация в плейлисте (выделение джинглов и рекламы)
- перекодировщик файлов (mp3->wma etc...)
- граббер CD
- поддержка профилей (индивидуальные настройки для каждого пользователя)
- редактор тегов для всех типов файлов
- комментарии - к каждому треку можно дописать комментарий
- функция "плейлист в плейлисте"

iikoDJ help system. Copyright (c) Resto Software, Inc 2006-2007. http://www.iiko.ru


Лицензионное соглашение

Лицензионный договор с конечным пользователем

Важно! Прочтите внимательно нижеизложенное, прежде чем устанавливать или иным образом использовать приобретенный продукт iikoDJ. Любое использование Вами приобретенного продукта, в том числе его установка, означает Ваше согласие с условиями приведенного ниже Лицензионного договора. Настоящий Лицензионный договор является юридически обязательным соглашением, заключаемым между Вами, Конечным Пользователем, под которым подразумевается, в том числе и организация, и компанией ООО «Ресто Софтвер». Соглашение заключается относительно указанного выше программного обеспечения, которое поставляется вместе с настоящим Лицензионным договором, включая все носители, печатные материалы и электронную документацию (далее по тексту - ПО).

Устанавливая или иным способом используя ПО, Вы подтверждаете, что настоящий Лицензионный договор был Вами прочитан, условия его Вам понятны, и Вы согласны использовать ПО в соответствии с ними. Настоящий Лицензионный договор считается заключенным с момента, когда Вы примете его условия, а именно: в процессе установки ПО отметите пункт «Я принимаю условия лицензионного договора» на экране Вашего компьютера и нажмете на кнопку «Далее»; договор сохраняет силу в течение всего срока действия авторского права на ПО.

«Компания ООО «Ресто Софтвер»» означает:
ООО «Ресто Софтвер» (зарегистрировано по адресу 129301, г. Москва, ул. Касаткина, д. 11, стр.1).
«ПО» - программное обеспечение iikoDJ, включая все носители, печатные материалы и электронную документацию.
«Вы», «Конечный Пользователь» - любое физическое лицо или организация, которые получили и используют ПО.

1. Предмет договора

1.1. При условии соблюдения Вами настоящего Лицензионного договора Компания ООО «Ресто Софтвер» предоставляет Вам неисключительное, не подлежащее передаче другому лицу ограниченное право («Лицензию») на использование ПО, включая любые изображения, фотографии, анимированные изображения, аудио- и видеокомпоненты, музыку, текст и дополнительные программы, входящие в состав ПО, а также сопроводительные материалы и копии ПО исключительно способами, указанными ниже. Все условия, оговоренные далее, относятся как к ПО в целом, так и ко всем его компонентам в отдельности.

2. Права на ПО и его компоненты

2.1. Компания ООО «Ресто Софтвер» гарантирует, что имеет все необходимые права на лицензирование и распространение ПО (в том числе любых включенных в него графических изображений, фотографий, текстов, анимированных изображений, аудио- и видеокомпонентов, музыки и дополнительных программ), а также сопровождающих ПО печатных материалов и всех копий ПО.
2.2. Настоящий Лицензионный договор не предоставляет Вам прав на интеллектуальную собственность и товарные знаки, принадлежащие Компании ООО «Ресто Софтвер».

3. Условия использования ПО

3.1. Если Дополнительным соглашением с ООО «Ресто Софтвер» или лицензией, поставляемой с ПО не установлено другое, то разрешается установить ПО только на одном компьютере. Если Вы хотите установить ПО на другой компьютер, сначала Вы должны удалить программу с компьютера, где она установлена первоначально.

4. Ограничения

4.1. Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:
4.1.1. Деассемблировать, декомпилировать (преобразовывать объектный код в исходный текст) ПО (включая программы, базы данных (в том числе словари) и другие компоненты ПО), за исключением случаев и только в объеме, явным образом разрешенном применимым законодательством.
4.1.2. Модифицировать, адаптировать или переводить ПО, в том числе вносить изменения в объектный код программ или баз данных к ним, за исключением тех изменений, которые вносятся средствами, включенными в комплект ПО и описанными в документации.
4.1.3. Сдавать в аренду, сублицензировать, передавать или уступать права, предоставленные Вам по настоящему Лицензионному договору, и любые другие права, связанные с ПО, третьим лицам, а также разрешать копировать ПО целиком или его части на другие компьютеры.
4.1.4. Создавать условия для использования ПО лицами, не имеющими прав на использование данного ПО, в том числе работающими с Вами в одной сети или многопользовательской системе.
4.1.5.Копировать или пытаться скопировать установочный диск с ПО частично или полностью. За все нелегальные копии ПО или созданного им файлов, с серийным номером Вашей копии ПО, Вы несете персональную ответственность.
4.1.6. Копировать все носители, печатные материалы и электронную документацию частично или полностью, или хранить ее в информационно-поисковой системе в любой форме, в виде фотокопий, записей, электронном или ином виде.
4.1.7. Удалять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

5. Расторжение договора

5.1. Если иное не оговорено в отдельном соглашении между Вами и Компанией ООО «Ресто Софтвер», настоящий Лицензионный договор действует до тех пор, пока он не будет расторгнут:
(i) при несоблюдении Вами его условий и ограничений. При прекращении действия настоящего Лицензионного договора Вы обязаны деинсталлировать ПО.
(ii) при уничтожении Вами всех копии ПО и сопровождающей его документации.

6. Гарантии и ограниченная ответственность

6.1. ПО и обновления поставляются «как есть», и Компания ООО «Ресто Софтвер» не предоставляет на них никаких гарантий. Компания ООО «Ресто Софтвер» не гарантирует и не может гарантировать производительность и результаты, которые Вы можете получить, используя ПО. Компания ООО «Ресто Софтвер» также не гарантирует, что ПО не содержит ошибок, будет удовлетворять Вашим требованиям или что ПО будет нормально функционировать при использовании совместно с ПО и оборудованием других производителей. Все риски, связанные с качеством работы и производительностью ПО, возлагаются на Вас.
6.2. Компания ООО «Ресто Софтвер» ни при каких обстоятельствах не несет перед Вами никакой ответственности за ущерб, вынужденные перерывы в деловой активности, потерю деловых либо иных данных или информации, претензии или расходы, косвенные или случайные убытки, а также упущенную выгоду и утерянные сбережения, вызванные использованием или связанные с использованием ПО, а также за ущерб, вызванный возможными ошибками и опечатками в ПО, даже если представителю Компании ООО «Ресто Софтвер» стало известно о возможности такого ущерба, потерь, претензий или расходов, равно как и за любые претензии со стороны третьих лиц.


Быстрый старт

Начало работы с программой

Перед началом работы рекомендуется выполнить следующие шаги:

1. Выбор языка интерфейса. Запустите плеер, нажмите View->Select language и выберите нужный язык интерфейса. Язык изменяется сразу для всех модулей программы.

2. Создание музыкальной базы. Выберите пункт меню Музыкальная база->Запустить. Добавьте в базу все папки, музыку из которых вы хотите использовать в эфире (чтобы добавить в базу папку или файл, нажмите в базе кнопки "Добавить папку" и "Добавить файл"). После того, как база будет готова, сохраните ее, нажав кнопку "Сохранить", например под именем "base.dfs" в подпапке "Database" каталога, куда вы установили программу. Закройте базу.

3. Подключение музыкальной базы к плееру. В плеере зайдите в настройки (кнопка на панели инструментов или через меню), в закладке "Общие" выберите файл с музыкальной базой, который был создан на предыдущем шаге.

4. Установка идентификаторов рекламы и джинглов. Идентификаторы для джинглов и рекламы используются для цветовой подсветки в плейлисте и для кроссфейдов. Если, допустим, для джинглов установлен идентификатор "jingle" то все файлы, в названии (или тегах название/исполнитель) которых есть слово "jingle" будут считаться джинглами. Остальные файлы, не распознанные как джингл или реклама, считаются музыкой.

5. Настройки кроссфейдов. В основном окне программы в закладке "кроссфейды" настройте параметры кроссфейдов для каждого типа файлов: точка микширования - время от конца текущего трека, когда будет запущен следующий трек, точка автозатухания - время, когда громкость файла начнет снижаться.

6. Джинглы. Можете также настроить список джинглов для быстрого доступа - их можно будет вызывать нажатием кнопок 1-9 на клавиатуре или на панели инструментов. Список джинглов настраивается через команду меню "Джинглы-> Назначить...". Опция "уровень эфира при запуске джингла" позволяет настроить громкость музыки во время воспроизведения джингла.

7. Настройка параметров воспроизведения - в настройках плеера, на закладке "Воспроизведение", нужно выбрать устройство для основного выхода и подслушки. Также нужно установить пару колонок, на которые будет выводиться звук.


Работа с плеером

В этом разделе описана работа с плеером.


Главное окно

Закладки

В главном окне плеера расположены несколько закладок.

Расписание
Составление расписание, подробнее - см. раздел Расписание.

Эффекты
На этой вкладке расположен эквалайзер, настройка уровня сигнала (Gain), индикаторы уровней левого и правого каналов, а также настройки темпа, частоты и тона. AutoAmp - если включена автоматическая регулировка уровня звука, здесь будет отображаться коэффициент усиления (например, 1 - звук не изменен, 2 - в 2 раза громче, 0.5 - в половину громкости и т.п.).

Информация о треке
Составление расписания, подробнее - см. раздел Расписание. Здесь можно посмотреть информацию о выделенном файле, а также редактировать теги.

Проводник
Позволяет выбирать файлы, папки и плейлисты на диске и добавлять их в активный плейлист программы двойным кликом или переносом мышью.

Поиск по музыкальной базе
Составление расписание, подробнее - см. раздел Расписание. Здесь осуществляется поиск по базе данных. В поле "Найти" вводите строку поиска, в "Индекс" - поле, в котором программа будет искать. В списке ниже будет результат поиска. Эти файлы можно добавить в плейлист. Поиск не учитывает регистр букв (т.е. "А" и "а" - одно и тоже).

Плейлисты

В программе iikoDJ можно одновременно работать с двумя плейлистами: Main и Temp.

Запускать на проигрывание можно только треки из плейлиста Main. Плейлист Temp может использоваться для редактирования плейлиста в то время, как идет проигрывание основного. Чтобы прослушать файл через второй выход, нужно нажать правую кнопку мыши на нужном треке и в появившемся меню выбрать "Подслушка...". Также можно нажать на значок наушников в колонке "Подслушка", или при работе в плейлисте Temp двойным кликом мыши на треке.


Настройки

Общие

Идентификаторы рекламы и джинглов - служат для отделения джинглов и рекламы от музыки. Идентификатор ищется в тегах название и исполнитель (достаточно, чтобы идентификатор был в одном из этих полей), затем в имени файла. Также задается цвет для обозначения рекламы и джинглов в плейлисте. Пример: идентификатор рекламы commercial, если у трека в теге исполнитель (и/или название) написано что-то вроде "Название трека-commercial" или "commercial название трека" то этот трек будет считаться рекламой.

Файл музыкальной базы - файл базы данных, который будет использоваться при поиске (закладка "Поиск" в основном окне) и при генерации плейлистов с помощью генератора. База данных создается в программе Musical Database, которую можно запустить из плеера - команда меню "Музыкальная база -> Запустить".

Создавать отчет - нужно ли создавать отчет о проигранных треках. Отчеты хранятся в папке Report, имя файла соответствует дате отчета. В отчет также будут входить ошибки, которые возникли при воспроизведении.

Шкала громкости - устанавливает тип шкалы громкости, все регуляторы громкости в программе, в т.ч. и кроссфейд будут использовать этот тип шкалы.
Создавать отчет - надо ли создавать отчет о проигранных треках. Отчеты хранятся в папке Report, имя файла соответствует дате отчета. В отчет также будут входить ошибки, которые возникли при воспроизведении.

Детектор тишины

Здесь можно включить/выключить детектор тишины (т.е. если программа молчит то детектор тишины это исправит). На этой закладке устанавливается время тишины после которого срабатывает детектор и действие при обнаружении тишины.

Конвертер

Выход - папка, в которую будут сохраняться конвертированные файлы.
Кодек - алгоритм сжатия. По умолчанию можно сжимать с разным качеством в MP3 и OGG, также можно использовать любой другой command-line кодек.
Поля имя, команда, а также кнопки Добавить, Сохранить, Удалить предназначены для создания и редактирования пресетов.

Система

Размер буфера - размер буфера воспроизведения. Если программа "заикается", нужно увеличить значение, для уменьшения загрузки процессора - уменьшить. Чем больше это значение, тем больше задержка при применении эффектов. Рекомендуется установить 0,5 или 1 секунду.

Включить эффект Tempo - если не планируется использовать эффекты изменения частоты, темпа и тональности, то рекомендуется выключить.

Уровень Mute - уровень в дБ, на который понизится громкость при приглушении (кнопка Mute на панели инструментов).

Линейный вход/Микрофон

Раздел LINE.IN:
Здесь выбирается устройство и вход. Эти параметры будут использованы при включении линейного входа через файл Line.In, если не установлен параметр "Включать линейный вход напрямую".

Раздел MIC:
В этом разделе настраивается микрофон. В последнем списке выберите вход, куда у Вас подключен микрофон. Эти параметры будут также использованы для линейного входа если включена опция "Включать лин. вход напрямую". Крайне не рекомендуется устанавливать Wave, потому что кнопка Mic в этом случае будет управлять главным выходом карты.

Включать лин. вход напрямую. Если включено, то линейный вход будет включаться напрямую, без обработки программой. В этом случае, не будет задержки звука из-за применения эффектов, но нельзя будет применять эффекты или вообще как-то влиять на воспроизведение кроме как включить/выключить. Не будет визуализации и индикатора уровней. Если выключено - тогда программа будет полностью обрабатывать сигнал с линейного входа, применять эффекты и показывать/регулировать уровень, но будет задержка звука, она зависит от используемого оборудования и настроек программы (размер буфера + период обновления (100мс)).

Плагины Winamp

Разрешить использовать плагины Winamp - использовать или нет плагины Winamp для обработки звука. Если не планируется использовать эти плагины, то рекомендуется выключить для повышения надежности программы.
Плагины, которые Вы хотите использовать, должны быть скопированы в папку Plugins\Winamp. На этой вкладке также выбирается, какой из плагинов будет активным.

Воспроизведение

Обрезать тишину в начале и конце файла - если отмечено, то программа автоматически уберет тишину в начале и конце трека. Настройка чувствительности делается через параметр Player.ini, параметр Threshold.

Основной выход - главный выход программы, используется для проигрывания плейлиста, джинглов, расписания и т.п. Здесь устанавливается устройство и, в случае многоканальной карты, пара колонок.

2-й выход - второстепенный выход для подслушки. Настройки те же, что и у основного выхода. Режим стерео сплит - будет использоваться устройство и пара колонок основного выхода, в правом канале будет играть эфир, в левом - подслушка.

Программа

Запускать с Windows - программа будет автоматически запускаться вместе с Windows

Предотвращать повторный запуск - если включено, то можно будет запустить только одну копию программы

Регистрировать форматы файлов - при включении этой опции файлы плейлистов (m3u) и музыкальные файлы (mp3, ogg, wav...) будут открываться с помощью RadoBOSS.

Кнопка на панели задач - оставлять ли кнопку программы iikoDJ на панели задач

При запуске программы:
- запустить плейлист - при запуске программы сразу начнет проигрываться плейлист
- возобновить проигрывание - при запуске программы плейлист возобновит проигрывание с того же места

Приоритет - устанавливается уровень приоритета программы в системе. Чем выше, тем меньше вероятность "заикания" звука. Для стабильной работы рекомендуется High. Не рекомендуется Real-Time (наивысший), т.к. это может плохо сказаться на стабильности системы.

Действие кнопки "Х" - действие, которое будет совершаться по нажатию на "крестик" в заголовке окна. Варианты: свернуть, закрыть.

Вид

Фон плейлиста, цвет текста в плейлисте - устанавливается цвета элементов плейлиста
Элементы управления: устанавливается, какие элементы управления будут доступны.

Кроссфейды

Настройки кроссфейдов:
Точка автозатухания - время от конца трека, когда громкость файла начнет снижаться.
Точка микширования - время от конца трека, когда будет запущен следующий трек.
Точка автоподъема - время в течение которого громкость трека будет наращиваться при его запуске.

Существуют различные настройки кроссфейдов для разных типов файлов: музыка, реклама и джинглы. Идентификаторы рекламы и джинглов устанавливаются в окне "Настройки". Идентификаторы используются для отделения рекламы и джинглов от музыки. Например, для джинглов установлен идентификатор "jingle", тогда все файлы, в названии (или тегах название/исполнитель) которых есть слово "jingle" будут считаться джинглами, и микшироваться по настройкам для джинглов. Аналогично для рекламы.

Индивидуальный кроссфейд. Для любого файла можно назначить индивидуальный кроссфейд, он имеет приоритет над настройками кроссфейдов в программе. Индивидуальный кроссфейд прописывается в тег (название/исполнитель) или, если у файла нет тега, то в имя файла в формате: ^время (в секундах). Например, если в названии файла написано "Track1^4.5.mp3" то этот трек будет микшироваться с точкой автозатухания и микширования равными 4.5 сек, точка автоподъема равна 0. Желательно писать параметры индивидуального кроссфейда в тег (при изменении имени файла надо будет также обновить базу и все плейлисты, где встречается старое имя).

Цвет

Настройки цветовой подсветки треков в плейлисте по полю "Комментарий". Все треки, у которых в комментарии встречается заданное слово, будут подсвечены соответствующим цветом.


Расписание

Через расписание можно запускать как файлы, так и плейлисты. Расписание настраивается в главном окне плеера. Опция "Вкл" - указывает, включено ли расписание.

В списке отображается следующая информация:
Время - на какое время назначен выход блока
День - дни недели, в которые должен выходить блок
Файл - название запускаемого трека или плейлиста
Уровень громкости - когда запустится блок, будет установлен этот уровень громкости эфира
Папка - путь к запускаемому файлу

Кнопки управления списком:
"Добавить..." позволяет добавить новый элемент расписания.
"Изменить..." изменяет параметры выделенного элемента
"Удалить" - удаляет выделенный элемент
"Запустить блок" - запустить выделенное задание независимо от того, на какое время оно запланировано

При нажатии кнопок "Добавить" или "Изменить" появляется окно параметров элемента расписания:

Название плейлиста, композиции или команда - имя файла, который будет запущен по расписанию. Это поле может также содержать одну из команд:

  • stop - остановить воспроизведение

  • next - перейти к следующему треку

  • prev - перейти к предыдущему треку

Время запуска - здесь указывается время выхода блока
День запуска - назначить конкретную дату выхода или выбрать дни недели запуска блока
Загружать в случайном порядке - если в поле "Имя файла" указан плейлист, то перед добавлением в основной список он будет перемешан
Зациклить список - при запуске блока активировать опцию "Зациклить список"
Запускать блок строго по времени - если включен, то блок будет запущен точно в то время, которое указано в поле "Время", иначе он встанет в очередь и будет запущен после того, как отыграет текущий трек.
Запускать поверх эфира - если установлен, то трек будет запущен поверх основного эфира. При этом имеется возможность понизить громкость эфира регулятором "уровень музыки", который расположен ниже.
Удалять предыдущее расписание из плейлиста - при запуске задания удалятся все треки предыдущих заданий, которые были в плейлисте
Время выравнивания громкости с уровня предыдущего блока - задается время в секундах для плавного изменения уровня громкости с текущего уровня эфира до указанного в поле "Установить громкость"


Кроссфейды

Настройки кроссфейдов:
Точка автозатухания - время от конца трека, когда громкость файла начнет снижаться.
Точка микширования - время от конца трека, когда будет запущен следующий трек.
Точка автоподъема - время в течение которого громкость трека будет наращиваться при его запуске.

Существуют различные настройки кроссфейдов для разных типов файлов: музыка, реклама и джинглы. Идентификаторы рекламы и джинглов устанавливаются в окне "Настройки". Идентификаторы используются для отделения рекламы и джинглов от музыки. Например, для джинглов установлен идентификатор "jingle", тогда все файлы, в названии (или тегах название/исполнитель) которых есть слово "jingle" будут считаться джинглами, и микшироваться по настройкам для джинглов. Аналогично для рекламы.

Индивидуальный кроссфейд. Для любого файла можно назначить индивидуальный кроссфейд, он имеет приоритет над настройками кроссфейдов в программе. Индивидуальный кроссфейд прописывается в тег (название/исполнитель) или, если у файла нет тега, то в имя файла в формате: ^время (в секундах). Например, если в названии файла написано "Track1^4.5.mp3" то этот трек будет микшироваться с точкой автозатухания и микширования равными 4.5 сек, точка автоподъема равна 0. Желательно писать параметры индивидуального кроссфейда в тег (при изменении имени файла надо будет также обновить базу и все плейлисты, где встречается старое имя).


Полезные советы

1. Статусная строка: показывает загрузку процессора аудиодвижком программы и загрузку памяти (RAM) - общую (т.е. всех программ, запущенных в системе), приоритет, состояние детектора тишины. Переключение состояния детектора тишины двойным кликом мыши по полю "Детектор тишины".

2. Левый клик по часам - изменить цвет шрифта.

3. Левый клик по метке времени - переключает состояние: сколько прошло от начала трека/сколько осталось. Правый клик - включает вторую метку, показывающую противоположное значение.

4. Можно включить/выключить визуализацию кликнув по ней.

5. Чтобы выделить текущий (проигрываемый) трек в плейлисте нужно кликнуть по полю "В эфире".

6. При нажатии на стоп трек останавливается не сразу, а плавно затухает. Чтобы резко остановить трек нужно еще раз нажать на стоп.

7. Второй плейлист "Temp" может быть использован для редактирования плейлистов во время воспроизведения основного плейлиста.

8. Нажав "Т" (англ.) можно вызвать блокнот, в котором можно к каждому файлу приписать текст (комментарий), или просмотреть текст, который был введен до этого. Текст хранится вне музыкального файла.

9. Чтобы все файлы игрались на одной громкости настройте эффект "AutoAmp". Для начала можно попробовать встроенные пресеты. Подробнее здесь.

10. Кликните правой кнопкой по любому треку из плейлиста и выберите "Следующий трек". Этот трек будет играть следующим после того как кончится текущий или вы нажмете ">>|"

11. Можно выбрать режим работы кнопки "Break" кликом правой кнопки мыши: сработать только для одного трека (т.е. после срабатывания кнопка выключится) или оставаться всегда активной.


Как...

Работа с программой

Настройка расписания музыки на неделю
Я хочу установить в пятницу и субботу вечером танцевальную музыку, а в остальное время обычную музыку не очень громко. Как мне это сделать?
По умолчанию в установку системы iikoDJ входит 3 плейлиста для примера ("День.m3u", "Вечер.m3u", "Ночь.m3u"), которые размещены в списке расписания. Это позволит многим пользователям разобраться с расписанием не обращаясь к документации.

Ниже мы расскажем, как по шагам создать свое расписание.

Шаг 1. Создайте 2 плейлиста. "Танцевальный вечер.m3u" и "Спокойный день.m3u". Pапустите музыкальную базу, добавьте в нее музыкальные треки - для этого в окне музыкальной базы нажмите кнопку " Добавить папку" и выберите папку с танцевальной музыкой). Чтобы создать плейлист, нажмите кнопку "Сохранить плейлист" и введите имя "Танцевальный вечер.m3u". Затем очистите базу (меню Действия -> Очистить), добавьте треки со спокойной музыкой и сохраните плейлист как "Спокойный день.m3u"

Шаг 2. Запустите плеер, удалите из расписания все имеющиеся задания кнопкой "Удалить".

Шаг 3. Нажмите кнопку "Добавить...", откроется окно "Назначение музыкального блока". Нажмиме кнопку "..." справа от поля "Имя файла" и выберите плейлист "Танцевальный вечер.m3u", созданный на шаге 1. Установите время запуска 18:00. В разделе "День запуска" снимите отметку с опции "Запускать по дате", а также со всех дней кроме "Пт" и "Сб". Рекомендуем также включить опции "Загружать в случайном порядке", "Зациклить список" и "Удалять предыдущее расписание из плейлиста". Подробнее о параметрах запусках можно прочитать в разделе Расписание. Нажмите ОК для добавления нового задания в расписание.

Шаг 4. Аналогичен шагу 3 за исключением того, что имя плейлиста "Спокойный день.m3u", время запуска - 09.00 и дни запуска "Все".

Шаг 5. Проверьте, включено ли расписание (отметка "Включить расписание" над списком).

Теперь при запуске плеера автоматически будет загружаться подходящий по времени и дню плейлист, т.е. все дни с понедельника по пятницу будет играть плейлист "Спокойный день.m3u", а по вечерам пятницы и субботы будет загружаться плейлист "Танцевальный вечер.m3u".

Как включить линейный вход/микрофон?
Вариант А: Нужно добавить в плейлист файл с именем "line.in" и запустить его (Плейлист->Добавить LINE.IN). Используется вход, выбранный в настройках.
Замечания:
1. Если запустить линейный вход, он будет проигрываться до тех пор, пока не будет остановлен пользователем или не сработает расписание.
2. На линейный вход не действуют эффекты, которые меняют скорость воспроизведения.
3. Для исключения задержки звука можно отключить обработку линейного входа программой, подробнее здесь.

Вариант В: Нажмите кнопку "MIC" в главном окне программы. Пока кнопка находится в нажатом состоянии, микрофон будет работать поверх эфира. Эта кнопка просто активирует микрофонный вход аудиокарты (тот, который установлен в окне "Настройки").

Как сделать чтобы файлы играли на одной громкости?
Для этого нужно настроить эффект AutoAmp (нажмите кнопку "Эффекты..." в главном окне программы). Перед тем, как настраивать, рекомендуется использовать встроенный пресет Normal. Можно также настроить эффект самостоятельно, однако неправильная настройка может привести к пропаданию звука или увеличению помех.
Параметры настройки:
Target lev. - желаемый уровень. К нему будет приводиться громкость всех файлов. Значения от 0 до 1. По умолчанию 1. (Значение этого параметра, как и параметра Quiet lev. показывает коэффициент изменения сигнала, т.е. значение 0.5 значит пониженная в два раза громкость, 2 - в два раза громче).
Quiet lev. - уровень тишины. Если уровень звука ниже этого, то программа считает это тишиной, и не будет его усиливать. Значения от 0 до 1, по умолчанию 0,15.
Rate - скорость изменения громкости. Чем меньше, тем более плавно будет регулироваться громкость, но время достижения конечного уровня будет больше. Значения от 0.01 до 1, по умолчанию 0.05.
Delay - задержка перед изменением громкости (сек). От 0.1 до 10, по умолчанию 0.5.

Как повышать уровень рекламы и объявлений в iikoDJ?
В настройках нужно указать идентификатор рекламы (описано в справочной системе в программе) и там же указать повышение уровня в дБ. Тогда все файлы, которые подходят под критерий "реклама", будут звучать громче, чем фоновая музыка. Аналогично можно сделать и для джинглов.

Настроить линейный вход, чтобы он начинал воспроизводиться и выключался в определенное время.
Для этого настраивается планировщик (в главном окне iikoDJ). Для включения линейного входа добавляется новый элемент расписания, указывается время запуска, имя файла для запуска установите Line.In - специальный файл для запуска линейного входа (команда Плейлист->Добавить LINE.IN). Линейный вход будет проигрываться до тех пор, пока его не выключат вручную или не сработает расписание. Чтобы выключить линейный вход по расписанию, добавляется новое задание в расписании, устанавливается нужное время и дата, вместо имени файла - ключевое слово stop или next (без путей, только одно слово). stop просто остановит проигрывание, next - переключит на следующий трек в плейлисте. ВАЖНО! При создании элементов расписания обязательно нужно указывать флаг "запускать немедленно".

Как настроить iikoDJ, чтобы в определенное время выводилась реклама, а все остальное время работала ретрансляция линейного входа?
Есть 2 способа:
1) Добавить файл Line.In в плейлист (Плейлист->Добавить LINE.IN) и запустить - включится ретрансляция, включить опцию "повтор плейлиста" (кнопка находится справа от кнопки RND), в расписание должны быть занесены все блоки рекламы. В итоге, все время работает файл Line.In (т.е. ретрансляция), в нужные моменты прерывается на рекламу из расписания, а за счет включенного повтора плейлиста, после окончания рекламы опять запускается проигрывание линейного входа.
2) Без использования повтора плейлиста. Тоже самое, что и в 1), только файл Line.In нужно добавить несколько раз (от 10 до 100 и более, в зависимости от того, сколько блоков рекламы планируется выпустить, и сколько программа будет работать без присмотра, т.к. после выхода каждого рекламного блока проигрывание будет смещаться на 1 файл ниже).
ВАЖНО! При создании элементов расписания обязательно нужно указывать флаг "запускать немедленно".

Нужно с одного компьютера озвучить несколько помещений, используя разные выходы многоканальной звуковой карты, как правильно настроить программу?
Для озвучки нескольких помещений требуется установить нужное количество копий программы (столько, сколько помещений) в разные папки. Потом, для каждой копии программы нужно изменить настройки:
1. Отключить опцию "Предотвращать повторный запуск" - это позволит одновременно запустить программы из каждой папки.
2. Настроить выход - выбрать переднюю (front), заднюю (rear), боковую (side) или центральную (center/LFE) пару колонок - каждая программа будет выводить стерео звук на свою пару колонок.


Музыкальная база

Построение музыкальной базы необходимо для более удобной работы с программой. На основе базы будет происходить быстрый поиск в плеере, база необходима для генератора плейлистов и с помощью базы составляется и редактируется база данных музыкальных треков.

Вызывается из главного меню плеера (Музыкальная база -> Запустить).

Назначение кнопок:

Добавить папку - добавляет в список все файлы из указанной папки (в том числе и из подпапок)

Сохранить плейлист - сохраняет весь список в плейлисте

Отправить в Main под курсов - трек будет добавлен в список Main после выделенного трека, выделение будет перемещено на один трек вниз.

В плеер - отправить в плейлист плеера (в выпадающем меню выбирается назначение в какое именно место добавить трек)

Справа от кнопок расположен мини-плеер для прослушивания треков прямо в базе.

Поле ввода под списком служит для поиска по базе.

Контекстное меню (вызывается правым кликом мыши в списке)

Удалить - удаляет файл из базы

Удалить файл с диска - физически удаляет файл с винчестера (в корзину) и из базы

Копировать файл (ы)… - копирует выделенный файл (и) в указанную папку

Редактор тегов - редактор тегов с функцией заполнения теговой информации по шаблону. Для этого надо выделить группу треков. Затем вызвать редактор тегов и занести в пустые поля нужную информацию. Автоматически у всех выделенных треков появится введенная информация. Стирается теговая информация также легко, в те поля, которые надо удалить ставиться пробел.

Если какое-либо поле оставлено пустым, оно не перезаписывается. Если вам необходимо при массовом редактировании оставить стиль у всех треков без изменения, поставьте флаг в опции Не изменять, в противном случает стиль будет удален.

Пересчитать время - считает длину треков

Настройки:

Общие:

Не добавлять файлы с пустыми тегами - программа пропустит файлы, у которых нет тега.

Не показывать сообщения об ошибках - не будут показаны сообщения об ошибках, возникающих во время добавления файлов в базу.

Не перепроверять время - при пересчете времени будет определяться время только у файлов, у которых оно неизвестно.

Считать время сразу - считать время сразу после добавления файлов в базу, иначе в колонке "Время" будет написано "??:??". Время можно пересчитать выбрав пункт меню (правая кнопка на списке) "Пересчитать время".

Заменять файлы при копировании - при копировании файлов в папку существующие файлы с таким же именем будут заменяться.

При загрузке открывать последнюю базу - при запуске базы будет загружена тот же файл, с которым велась работа в прошлый раз

Быстрый поиск - если отмечено, поиск в базе будет осуществляться по мере ввода, иначе - после нажатия кнопки "Поиск".

Если нет тега, читать из имени файла - если у файла нет тега, программа может попытаться извлечь исполнителя и название из имени файла.

Цвет - выделение цветом файлов определенного типа

Подслушка - выберите здесь, куда должен воспроизводить мини-плеер в базе.


Конфигурационные файлы

Настройки программы можно также менять через конфигурационные файлы. Обычно это требуется для устранения неполадок или для тонкой настройки программы. Параметры, выделенные курсивом, можно изменить через окно настроек программы.

system.ini

Секция [Options]
BufferLength - размер буфера в миллисекундах (1 сек.=1000мс). Большой размер буфера рекомендуется для медленных компьютеров, но чем больше размер буфера тем больше задержка перед изменением эффектов (эквалайзер и т.п.). По умолчанию - 500.

FXTempo - разрешить использование эффектов tempo, pitch и samplerate. Для экономии ресурсов рекомендуется выключить (0). По умолчанию включено (1).

UseLineIn - использовать (1) или нет (0) микрофонный вход. Если вы не используете микрофон или линейный вход, можете выключить этот параметр. Иногда включение микрофона может приводить к тому, что не будет работать подслушка в режиме "Front/Rear split". Это не влияет на работу кнопки "MIC" в главном окне программы (она будет работать всегда).

NoLineFx - не применять эффекты для линейного входа. Если равно 0, то линейный вход будет включен напрямую, без обработки программой (подробнее). Если 1 - то можно будет применять эффекты, и т.п., но будет задержка.

Секция [Equalizer]
BandsNum - количество полос эквалайзера от 0 до 12, 0 - выключить эквалайзер (для экономии памяти и ресурсов).

Bandwidth - ширина полосы эквалайзера, октавы от 0 до 4, можно вводть дробные значения, например, 1.5.
Freq0 ... Freq11 - частоты полос, в Гц.

Секция [Device]
MainDev - номер основного устройства вывода звука (по умолчанию MainDev=1)
SecondDev - номер дополнительного устройства (по умолчанию 2)

Чтобы определить какие номера соответствуют вашим картам используйте утилиту DevList.exe в папке с программой.

player.ini

Секция [Options]
Comment - если включен, в плейлисте будет показано наличие комментария к треку. Однако включение этого параметра может увеличить время загрузки плейлиста. Если вы работаете с маленькими плейлистами (менее 1000 треков), или у вас быстрый компьютер, включит этот параметр (1). Если плейлисты загружаются долго, выключите (0).

FadeSign='^' - через какой символ обозначать индивидуальный кроссфейд. Например если в имени файла (или теге название/исполнитель) написать ^1.2 то файл будет миксоваться с временем затухания и микширования равным 1.2 независимо от настроек программы.

VisUpdateDelay - интервал (в мс) обновления визуализации. По умолчанию=20, что соответствует 50 кадров в секунду (50=1000/20)

Threshold - уровень звука для детектора тишины (отрезать тишину в начале и конце файла). Если ниже этого уровня, то программа считает, что звука нет (тишина). Значение по умолчанию=50.


Контакты

Если у вас есть вопросы по использованию программы, пожелания по улучшению или вы нашли ошибку просьба написать письмо в нашу службу поддержки: support@djsoft.net.

Последнюю версию программы всегда можно скачать на сайте http://www.djsoft.net.